toggle menu
mapsglmaps
androidJvm
switch theme
search in API
mapsglmaps
/
com.xweather.mapsgl.sources.source.spec
/
EncodedSourceDescriptor
/
EncodedSourceDescriptor
Encoded
Source
Descriptor
constructor
(
id
:
String
,
url
:
String
?
=
null
,
metadataUrl
:
String
?
=
null
,
minZoom
:
Float
?
=
null
,
maxZoom
:
Float
?
=
null
,
bounds
:
LatLonBounds
?
=
null
,
tileSize
:
TileSize
?
=
null
,
attribution
:
String
?
=
null
,
authenticator
:
XweatherAuthenticator
?
=
null
,
datasets
:
List
<
EncodedDataset
>
?
=
null
)